Checking in at 28k and a friendly reminder to fasten your levers - Yamaha SCR950 Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 09-11-2020, 10:06 AM Thread Starter
Senior Member
 
yoitsemo's Avatar
 
Join Date: Aug 2017
Location: Gainesville, FL
Posts: 218
Checking in at 28k and a friendly reminder to fasten your levers

Hey everyone. So covid has put a damper on my mileage these last few months so I haven't passed 30k yet but I can't really complain.

At just around 28k miles and the bike is still so much fun to ride and the maintenance has been incredibly low (definitely knock on wood for that one). My only guess is that the regular riding is keeping things in check but who knows. This is my first bike and maybe I just got lucky.

Currently on my 2nd pair of Michelin Pilot Activs and don't really have anything bad to say about these tires. I ride strictly on pavement and they've done me very well. You can easily squeeze 10-12k miles or more even. If I had a garage the front would have lasted longer but sun exposure and FL weather had the early stages of dry rot showing so I went ahead and got it replaced the same time as the rear.

Shake in the handlebar between 40-50mph is still there and I guess it's gotten a little worse since I first started riding but it hasn't caused me any problems.

A problem that I did have in the early days of owning the bike resurfaced recently though. Now maybe I'm just heavy footed on the rear brake lever, but there was a time when the lever started getting loose and had a noticable "wiggle" to it if you grabbed it and tried to move it by hand side to side. I tightened it up a few times and then after a while it stopped getting loose until recently.

Now I hadn't checked it out in a long time, maybe a year or more, but turns out it managed to entirely unseat itself so that when I was to press the lever, the whole thing moved with my foot. Worried I might have even bent the bolt that had come loose, I quickly was able to get parked (this happened in town fortunately) and used a hex key to screw it back in. Honestly could not believe it had managed to unscrew entirely but luckily it's designed to not fall out and the lever has plenty of other parts keeping it attached to the bike.

Anyways, check yours. Make sure everything is fastened tight. This might just be a "me" thing, but that was a feeling I was not expecting and hope to never again.
yoitsemo is offline  
post #2 of 4 (permalink) Old 09-11-2020, 08:35 PM
Senior Member
 
jevers478@gmail.com's Avatar
 
Join Date: Mar 2018
Location: Savage,MN
Posts: 609
Garage
Wow! Thanks for the heads up! I'll be checking mine tomorrow. I wonder if a little Loc Tite would cure this problem? I know that feeling when you push on the pedal and nothing happens! I had bought a basket case dirt bike, got it all put back together and took it out for a ride. Well guess what? I pushed on the rear brake lever and nothing happened! Here i had installed the linkage rod upside-down! Lesson learned... jevers

[email protected] is offline  
post #3 of 4 (permalink) Old 09-14-2020, 11:53 AM Thread Starter
Senior Member
 
yoitsemo's Avatar
 
Join Date: Aug 2017
Location: Gainesville, FL
Posts: 218
Oh man, what a scare! lol

To be fair I do always try to test both my front and rear breaks before I ride anywhere just by engaging them each separately and rocking myself forward and back a just a bit.

Quote:
Originally Posted by [email protected] View Post
Wow! Thanks for the heads up! I'll be checking mine tomorrow. I wonder if a little Loc Tite would cure this problem? I know that feeling when you push on the pedal and nothing happens! I had bought a basket case dirt bike, got it all put back together and took it out for a ride. Well guess what? I pushed on the rear brake lever and nothing happened! Here i had installed the linkage rod upside-down! Lesson learned... jevers
yoitsemo is offline  
 
post #4 of 4 (permalink) Old 09-15-2020, 07:15 PM
Junior Member
 
Join Date: Nov 2018
Posts: 10
Did you lash the valves in this 28,000 miles

Please let me know what engine maintenance you might of done
Thanks
Dan K
Dkaragozian is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome