Yamaha SCR950 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I went to a bible study last night and on my way home at about 35mph the bike flashed the check engine light twice. (On, off, on) Then the whole bike shut down and had absolutely no power. Turn the key on and nothing happens. I looked for and wire damage to see if maybe mice got in there but did not see anything. Battery is at 12.7v and charges at 14.3v. Terminals seem tight. Fuses seem good. We loaded it into my buddy's truck and got it back to my place and it turned back on and fired right up. Then this morning it started fine as well. Has anyone discovered any problems like this with their bike?

Ps67
 

·
Registered
Joined
·
74 Posts
I went to a bible study last night and on my way home at about 35mph the bike flashed the check engine light twice. (On, off, on) Then the whole bike shut down and had absolutely no power. Turn the key on and nothing happens. I looked for and wire damage to see if maybe mice got in there but did not see anything. Battery is at 12.7v and charges at 14.3v. Terminals seem tight. Fuses seem good. We loaded it into my buddy's truck and got it back to my place and it turned back on and fired right up. Then this morning it started fine as well. Has anyone discovered any problems like this with their bike?

Ps67
I haven't had a similar problem on my SCR. Do you have any aftermarket electrical/electronic parts on the bike such as a fuel management module? You probably would've already thought of that if you did.
 
1 - 2 of 2 Posts
Top